Страниц: [1] 2
  Печать  
Автор Тема: Пользователю: Установка и настройка XFree  (Прочитано 17747 раз)
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« : Апреля 22, 2003, 03:45:00 pm »

http://qnx.org.ru/docs-devel/xfree.html

Автор: Дмитрий Алексеев.

Как установить и настроить иксы на машине с QNX, как установить модемную связь без использования phdialer, как запускать приложения для Photon в X и без использования phindows и т.д.

Если чего-то не хватает, или где-то ошибся - пишите, исправим.
Записан
olej
QOR.Team
****
Offline Offline

Сообщений: 42



Просмотр профиля
« Ответ #1 : Апреля 25, 2003, 02:38:00 pm »


dmi пишет:
Как установить и настроить иксы на машине с QNX, как установить модемную связь без использования phdialer, как запускать приложения для Photon в X и без использования phindows и т.д.

Если чего-то не хватает, или где-то ошибся - пишите, исправим.


Очень хорошая статья - рекомендую почитать всем, даже тем, кого subj не интересует.

Единственное, что у меня из описанного не сработало - wmaker - на 2-х компах с различными видеоподсистемами (Matrox G400 & S3 Virge GX/DX) - падает в core - хотя другие альтернативные оконные менеджеры - всё ОК. Но, может, это связано с более старыми редакциями - я возился с subj в период 6-й редакции статьи, а теперь ужо - 9-я ...
Записан
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« Ответ #2 : Апреля 25, 2003, 03:04:00 pm »

Скорее я что-то накосячил. Пишите - подробно описывайте, что и где ломается, переделаю. Там, с сожалению, не все отшлифовано
Записан
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« Ответ #3 : Апреля 26, 2003, 01:50:00 am »

Меня тут поправили:  Jean-Claude MICHOT  отношения к портированию не имеет.

Изначально xfree была собрана для qnx4 Sebastien Marineau ( QSS ), Igor Kovalenko (atm Motorola), Frank Liu....

http://qnxfree.sourceforge.net/qnxfree86.html - вот откуда все пошло После переезда Игоря ftp сервер был закрыт.
Записан
187
Гость
« Ответ #4 : Апреля 26, 2003, 04:34:00 pm »


Olej пишет:
..

Единственное, что у меня из описанного не сработало - wmaker - на 2-х компах с различными видеоподсистемами (Matrox G400 & S3 Virge GX/DX) - падает в core - хотя другие альтернативные оконные менеджеры - всё ОК. Но, может, это связано с более старыми редакциями - я возился с subj в период 6-й редакции статьи, а теперь ужо - 9-я ...

та же чепуха только видео тут IMHO не причем. У меня S3trio3D2x, ставил на 620nc все красиво, появляется левая-верхняя скрепка и всё - ошибка, перегрузка - новый менеджер и т.д. в /var/core, чтоли, корка gdb пишет что запись в ffffffff.
Записан
olej
QOR.Team
****
Offline Offline

Сообщений: 42



Просмотр профиля
« Ответ #5 : Апреля 26, 2003, 06:07:00 pm »


та же чепуха только видео тут IMHO не причем. У меня S3trio3D2x, ставил на 620nc все красиво, появляется левая-верхняя скрепка и всё - ошибка, перегрузка - новый менеджер и т.д. в /var/core, чтоли, корка gdb пишет что запись в ffffffff.

Вот когда "всё - ошибка..." можно по правой клавише мышки в любой позиции открыть контекстное меню и выбрать альтернативный оконный менеджер ... и всё ОК.
Записан
187
Гость
« Ответ #6 : Апреля 26, 2003, 08:03:00 pm »


Olej пишет:

та же чепуха только видео тут IMHO не причем. У меня S3trio3D2x, ставил на 620nc все красиво, появляется левая-верхняя скрепка и всё - ошибка, перегрузка - новый менеджер и т.д. в /var/core, чтоли, корка gdb пишет что запись в ffffffff.

Вот когда "всё - ошибка..." можно по правой клавише мышки в любой позиции открыть контекстное меню и выбрать альтернативный оконный менеджер ... и всё ОК.

к примеру TWM..

[ Это Сообщение было отредактировано: 187 в 2003-04-30 19:37 ]
Записан
Landy
Jr. Member
**
Offline Offline

Сообщений: 65


Просмотр профиля WWW
« Ответ #7 : Апреля 29, 2003, 11:26:00 am »

При запуске xf86cfg  ошибка при инициализации драйвера видеокарточки
( mmap error ...)  на 6.2.1. Хотя на 6.2.0 с того же дистрибута все ставится нормально и пускается без проблем
Что-то видимо в 6.2.1 переделали ...(или не доделали)
Карта ATI 8мб
Записан
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« Ответ #8 : Апреля 29, 2003, 03:16:00 pm »


Landy пишет:
При запуске xf86cfg  ошибка при инициализации драйвера видеокарточки
( mmap error ...)  на 6.2.1. Хотя на 6.2.0 с того же дистрибута все ставится нормально и пускается без проблем
Что-то видимо в 6.2.1 переделали ...(или не доделали)
Карта ATI 8мб


да. Это известная проблема, но QSS отказывается ее таковой считать. Переделали off_t из unsigned в signed, поэтому появились проблемы с адресацией памяти. В частности mmap_device_memory() с флажком shared (указатель на выделенный участок памяти оказывается меньше нуля.).
Записан
Oleg
Гость
« Ответ #9 : Июня 18, 2003, 05:04:00 pm »

Комп
AMD-1000
GeForce 2 MX 100/200
У меня QNX 6.2.0

Установил XFree86 4.2 (2 CD диск с QNX)

Сделал
1) # touch /etc/system/config/nophoton
2) перезагрузка
3) Добавил следующие строки в файл .profile в домашнем каталоге:

PATH=$PATH:/opt/X11R6/bin
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/X11R6/lib:/usr/local/lib
export PATH LD_LIBRARY_PATH

/usr/photon/bin/devi-hirun -Pr ps2 mousedev

4) запустил xf86cfg
  Появляется экран в клеточку.
  Мышка двигается.
  И все. Дальше не туда и не сюда.

Только перезагрузка.

Что сделать?

[ Это Сообщение было отредактировано: Oleg в 2003-06-18 14:15 ]
Записан
klalafuda
QOR.Team
****
Offline Offline

Сообщений: 1


Просмотр профиля
« Ответ #10 : Июня 18, 2003, 05:20:00 pm »


Oleg пишет:
Комп
AMD-1000
GeForce 2 MX 100/200
У меня QNX 6.2.0

Установил XFree86 4.2 (2 CD диск с QNX)

Сделал
1) # touch /etc/system/config/nophoton
2) перезагрузка
3) Добавил следующие строки в файл .profile в домашнем каталоге:

PATH=$PATH:/opt/X11R6/bin
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/X11R6/lib:/usr/local/lib
export PATH LD_LIBRARY_PATH

/usr/photon/bin/devi-hirun -Pr ps2 mousedev

4) запустил xf86cfg
  Появляется экран в клеточку.
  Мышка двигается.
  И все. Дальше не туда и не сюда.

Только перезагрузка.

Что сделать?



собрать KDE3 или Gnome и запустить.

// wbr
Записан
olej
QOR.Team
****
Offline Offline

Сообщений: 42



Просмотр профиля
« Ответ #11 : Июня 18, 2003, 07:15:00 pm »


Oleg пишет:
Только перезагрузка.
Что сделать?


1.Только перезагрузка? А если Ctrl+Alt+BackSpase убить X?

2. Может быть вот что:
- X - сетевой (TCP) протокол...
- если ваш локальный хост не находит сам себя по петлевому интерфейсу 127.0.0.1 - то будет в точности такая картина;
- открываем "TCP/IP Configuration" в Self, смотрим Network -> Hostname (если вы его трогали) - если там написано (например) XXX...
- ...прописываем в /etc/hosts строчку:
127.0.0.1  XXX
- проверяем всё сначала...
Записан
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« Ответ #12 : Июня 19, 2003, 11:09:00 pm »

да нет, всё IMHO проще - мышку в левый верхний угол до упора. появится небольшое окошко с настройками.
Записан
Poupkine
Гость
« Ответ #13 : Июня 20, 2003, 04:41:00 pm »


dmi пишет:

Landy пишет:
При запуске xf86cfg  ошибка при инициализации драйвера видеокарточки
( mmap error ...)  на 6.2.1. Хотя на 6.2.0 с того же дистрибута все ставится нормально и пускается без проблем
Что-то видимо в 6.2.1 переделали ...(или не доделали)
Карта ATI 8мб


да. Это известная проблема, но QSS отказывается ее таковой считать. Переделали off_t из unsigned в signed, поэтому появились проблемы с адресацией памяти. В частности mmap_device_memory() с флажком shared (указатель на выделенный участок памяти оказывается меньше нуля.).


est' idei kak poborot' etu problemu?
Записан
dmi
QOR.Admin
*****
Offline Offline

Сообщений: 469



Просмотр профиля
« Ответ #14 : Июня 20, 2003, 04:49:00 pm »


Poupkine пишет:
est' idei kak poborot' etu problemu?


Все в support...
Либо - откат до 6.2 + точечное обновление с диска.
Записан
Страниц: [1] 2
  Печать  
 
Перейти в: